VS:Rotate3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Rotate3D rotates the most recently created three-dimensional object. Rotation values are applied about the respective axes.

PROCEDURE Rotate3D(
xAngle :REAL;
yAngle :REAL;
zAngle :REAL);
def vs.Rotate3D(xAngle, yAngle, zAngle):
    return None

Parameters

xAngle REAL Rotation about X-axis.
yAngle REAL Rotation about Y-axis
zAngle REAL Rotation about Z-axis.

Remarks

From Julian:

Rotate3D() can only be called after object creation. Duplication does not count as a newly created object, so use Set3DRot() instead. If you are rotating in more than one axis, you may need to use it 3 times, first Z, then Y then X rotation.

Example

VectorScript

BeginXtrd(0",4");
Rect(0",3",1",0");
EndXtrd;
Rotate3D(21d 10' 22",-18d 44' 50",-7d 5' 45");

Python


Version

Availability: from All Versions