VS:RightBound

From Vectorworks Developer
Revision as of 14:36, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See RightBoundN for a replacement.

Returns the x-coordinate of the bounding box (bottom right corner) of an object matching the search criteria If more than one object matches the search criteria, the function will return the sum of the coordinates of all the matching objects.

FUNCTION RightBound(
c :CRITERIA) : REAL;
def vs.RightBound(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

It would be nice if this would return the rightmost coordinate of the matching objects. Don't see how the sum of coordinates can be of any use.

Example

VectorScript

RightBValue:=RightBound(N='MyRect');

Python


Version

Availability: from All Versions

Deprecated: Vectorworks 2012