VS:RevolveWithRail

From Vectorworks Developer
Revision as of 14:36, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a NURBS surface or a group of surfaces by revolving a profile about an axis and following a rail guide curve on a plane perpendicular to the plane containing the axis and the profile.

FUNCTION RevolveWithRail(
profileH :HANDLE;
railH :HANDLE;
axisH :HANDLE) : HANDLE;
def vs.RevolveWithRail(profileH, railH, axisH):
    return HANDLE

Parameters

profileH HANDLE Handle to a NURBS curve to be used as the profile object.
railH HANDLE Handle to a NURBS curve to be used as the rail guide object
axisH HANDLE Handle to a linear NURBS curve about which the

Return Value

Handle to resulting NURBS surface.

Version

Availability: from VectorWorks10.0