VS:ReverseWallSides/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した壁の向きを逆にすることで壁の左右を切り替えます。

PROCEDURE ReverseWallSides(
theWall :HANDLE);
def vs.ReverseWallSides(theWall):
    return None

Parameters

theWall HANDLE 壁のハンドル

Example

PROCEDURE ReverseWallSidesExample;
VAR
	center_pt, start_pt, end_pt :VECTOR;
	h :HANDLE;
BEGIN
	center_pt.x := 0;
	center_pt.y := 0;
	start_pt.x := 100;
	start_pt.y := 0;
	end_pt.x := 0;
	end_pt.y := 100;
	RoundWall(center_pt.x, center_pt.y, start_pt.x, start_pt.y, end_pt.x, end_pt.y);
	h := LNewObj;
	ReverseWallSides(h);
END;
RUN(ReverseWallSidesExample);

Version

利用可能バージョン: VectorWorks10.0