VS:RetrieveOpenGLPrefs

From Vectorworks Developer
Revision as of 14:36, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the current OpenGl rendering options. Use textures boolean returns whether or not OpenGL rendering will apply renderworks textures. The tesselation detail parameter is returns the index of the detail pop-up in the OpenGL dialog. (0 = Low; 3 = Very High)

PROCEDURE RetrieveOpenGLPrefs(
VAR useTextures :BOOLEAN;
VAR tessellationDetail :INTEGER;
VAR useNURBS :BOOLEAN);
def vs.RetrieveOpenGLPrefs():
    return (useTextures, tessellationDetail, useNURBS)

Parameters

useTextures BOOLEAN Output parameter.
tessellationDetail INTEGER Output parameter.
useNURBS BOOLEAN Output parameter.

Version

Availability: from All Versions

This is drop-in function.