VS:RetrieveHLPrefs

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the current Hidden Line rendering preferences from data stored in the current drawing.

PROCEDURE RetrieveHLPrefs(
VAR smoothingAngle :REAL;
VAR lineStyle :INTEGER;
VAR shadeFactorIndex :INTEGER;
VAR doIntersections :BOOLEAN);
def vs.RetrieveHLPrefs():
    return (smoothingAngle, lineStyle, shadeFactorIndex, doIntersections)

Parameters

smoothingAngle REAL
lineStyle INTEGER
shadeFactorIndex INTEGER
doIntersections BOOLEAN

Version

Availability: from Vectorworks 2014