VS:RetrieveHLPrefs: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (1 revision)
 
(No difference)

Latest revision as of 17:37, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the current Hidden Line rendering preferences from data stored in the current drawing.

PROCEDURE RetrieveHLPrefs(
VAR smoothingAngle :REAL;
VAR lineStyle :INTEGER;
VAR shadeFactorIndex :INTEGER;
VAR doIntersections :BOOLEAN);
def vs.RetrieveHLPrefs():
    return (smoothingAngle, lineStyle, shadeFactorIndex, doIntersections)

Parameters

smoothingAngle REAL
lineStyle INTEGER
shadeFactorIndex INTEGER
doIntersections BOOLEAN

Version

Availability: from Vectorworks 2014