VS:RetrieveHLPrefs: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Retrieves the current Hidden Line rendering preferences from data stored in the current drawing.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE RetrieveHLPrefs(VAR smoothingAngle :REAL; VAR lineStyle :INTEGER; VAR shadeFactorIndex :INTEGER);
PROCEDURE RetrieveHLPrefs(VAR smoothingAngle:REAL; VAR lineStyle:INTEGER; VAR shadeFactorIndex:INTEGER; VAR doIntersections:BOOLEAN);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 25: Line 24:
smoothingAngle
smoothingAngle
REAL
REAL
Output parameter.
 
</line>
</line>
<line>
<line>
lineStyle
lineStyle
INTEGER
INTEGER
Output parameter.
 
</line>
</line>
<line>
<line>
shadeFactorIndex
shadeFactorIndex
INTEGER
INTEGER
Output parameter.
 
</line>
<line>
doIntersections
BOOLEAN
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 17:37, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the current Hidden Line rendering preferences from data stored in the current drawing.

PROCEDURE RetrieveHLPrefs(
VAR smoothingAngle :REAL;
VAR lineStyle :INTEGER;
VAR shadeFactorIndex :INTEGER;
VAR doIntersections :BOOLEAN);
def vs.RetrieveHLPrefs():
    return (smoothingAngle, lineStyle, shadeFactorIndex, doIntersections)

Parameters

smoothingAngle REAL
lineStyle INTEGER
shadeFactorIndex INTEGER
doIntersections BOOLEAN

Version

Availability: from Vectorworks 2014