VS:ResetDefStoryLevels

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Clears default story levels and repopulates the list from XML data files on disk.

FUNCTION ResetDefStoryLevels(
bDeleteExisting :BOOLEAN) : BOOLEAN;
def vs.ResetDefStoryLevels(bDeleteExisting):
    return BOOLEAN

Parameters

bDeleteExisting BOOLEAN Whether to delete existing default story levels before reloading the original defaults.

Return Value

Whether clearing the previous default story levels and loading the default list from disk succeeded.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetLevelTemplateName | VS:SetLevelTemplateName | VS:GetLevelTemplateInfo | VS:GetNumLevelTemplates

VS Functions:

[[VS:GetLevelTemplateName]] | [[VS:SetLevelTemplateName]] | [[VS:GetLevelTemplateInfo]]

| [[VS:GetNumLevelTemplates]]