VS:ReplaceIFCWithMap: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
(NULL not correct on VS --> NIL)
 
(3 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Deletes attached IFC Record from:
case 1: Object If the HANDLE is not NULL.
case 2: All Objects which corresponds to inStrObjName and HANDLE is NULL.
case 3: All Objects if inStrObjName is "allObjects" and HANDLE is NULL.
</desc>
</desc>


Line 23: Line 30:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
inStrObjName
hObject
STRING
HANDLE
Object's Handle.


</line>
</line>
<line>
<line>
inStrEntryName
inStrObjName
STRING
 
</line>
<line>
inStrFieldName
STRING
STRING
 
Object name.
</line>
<line>
bOptional
BOOLEAN


</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 49: Line 51:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := ReplaceIFCWithMap(NIL, 'Wall');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.ReplaceIFCWithMap(NULL, 'Wall')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 11:42, 11 June 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes attached IFC Record from:

case 1: Object If the HANDLE is not NULL.

case 2: All Objects which corresponds to inStrObjName and HANDLE is NULL.

case 3: All Objects if inStrObjName is "allObjects" and HANDLE is NULL.

FUNCTION ReplaceIFCWithMap(
hObject :HANDLE;
inStrObjName :STRING) : BOOLEAN;
def vs.ReplaceIFCWithMap(hObject, inStrObjName):
    return BOOLEAN

Parameters

hObject HANDLE Object's Handle.
inStrObjName STRING Object name.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := ReplaceIFCWithMap(NIL, 'Wall');
END;

RUN(Test);

Python

ok = vs.ReplaceIFCWithMap(NULL, 'Wall')

Version

Available from: Vectorworks 2017