VS:RenameClass

From Vectorworks Developer
Revision as of 14:36, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Renames the specified class.

All objects assigned to the class being renamed are updated.

PROCEDURE RenameClass(
className :STRING;
newName :STRING);
def vs.RenameClass(className, newName):
    return None

Parameters

className STRING Existing name of the class.
newName STRING New name for the class.

Remarks

It seems that when you try to rename a class to a class name that already exist, VW will create a new class with name, followed with "-2" or in case that the class name ends with a number, the number + 1.

Version

Availability: from VectorWorks8.5