VS:RemoveSubMtrlFromMtl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes a Simple material from a Compound material.

FUNCTION RemoveSubMtrlFromMtl(
hMaterial :HANDLE;
subMtrlName :STRING) : Boolean;
def vs.RemoveSubMtrlFromMtl(hMaterial, subMtrlName):
    return Boolean

Parameters

hMaterial HANDLE Handle of a Compound material
subMtrlName STRING Name of a Simple material to be deleted

Return Value

Returns true if successful; false otherwise. Returns false if the simple material is not found.

Version

Availability: from Vectorworks 2021