VS:RemoveStoryLevel

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes the Story Level matching 'levelType' from a Story. If 'bDeleteLayer' is true and the Story Level has an associated layer, the layer will be deleted as well.

FUNCTION RemoveStoryLevel(
storyHandle :HANDLE;
levelType :STRING;
bDeleteLayer :BOOLEAN) : BOOLEAN;
def vs.RemoveStoryLevel(storyHandle, levelType, bDeleteLayer):
    return BOOLEAN

Parameters

storyHandle HANDLE The handle of the story we want to deleted a Story Level from.
levelType STRING The level type of the Story Level we want to remove from 'storyHandle'.
bDeleteLayer BOOLEAN If this is true, and the requested Story Level has a layer associated with it, the layer will be deleted as well.

Return Value

Whether a Story Level with 'layerType' was found in the Story and successfully removed.

Example

VAR

storyHandle : HANDLE
success:BOOLEAN

BEGIN

storyHandle := CreateStory('Floor 1', '-1');
success := RemoveStoryLevel(storyHandle, 'Finish Floor', TRUE);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:CreateStory | VS:AddStoryLevel | VS:AddLevelFromTemplate | VS:SetLevelElevation | VS:GetLevelElevation

VS Functions:

[[VS:CreateStory]] | [[VS:AddStoryLevel]] | [[VS:AddLevelFromTemplate]] | [[VS:SetLevelElevation]]

| [[VS:GetLevelElevation]]