VS:RemoveImagePopupItem

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes the specified item from the image popup.

The item index lower boundary is 1 not 0. The upper boundary is the number of items in the image popup.

PROCEDURE RemoveImagePopupItem(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER);
def vs.RemoveImagePopupItem(dialogID, componentID, itemIndex):
    return None

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.
itemIndex INTEGER Index to item to be removed.

Example

VectorScript

RemoveImagePopupItem(dialogID, componentID, 4);

Variant implementation of RemoveAllImagePopupItems VS function:

PROCEDURE ManuallyRemoveAllImagePopupItems(dialogID, componentID :LONGINT);
VAR
	choicesCount, itemIndex: INTEGER;
BEGIN
	choicesCount 	:= GetNumImagePopupItems(dialogID, componentID);
	itemIndex 	:= 1;
	WHILE itemIndex <= choicesCount DO BEGIN
		RemoveImagePopupItem(dialogID, componentID, itemIndex);
		itemIndex := itemIndex + 1;
	END;
END;

Python


Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObject | VS:GetImagePopupObjectItemIndex | VS:SetImagePopupSelectedItem | VS:GetImagePopupSelectedItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObject]] | [[VS:GetImagePopupObjectItemIndex]] | [[VS:SetImagePopupSelectedItem]] | [[VS:GetImagePopupSelectedItem]]

| [[VS:RemoveAllImagePopupItems]]