VS:RealDialog

From Vectorworks Developer
Revision as of 15:14, 6 October 2015 by Jaredm (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function RealDialog displays a dialog box which requests the user to enter a REAL value. RealDialog automatically screens for valid numeric input.

FUNCTION RealDialog(
request :STRING;
default :STRING) : REAL;
def vs.RealDialog(request, default):
    return REAL

Parameters

request STRING Dialog user prompt string.
default STRING Default value for input field.

Example

VectorScript

RealValue:=RealDialog('Enter a real value:','0.00');

Python

realValue = vs.RealDialog('Enter a real value', '0.00')

Version

Availability: from All Versions