VS:RealDialog: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
 
Line 45: Line 45:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
realValue = vs.RealDialog('Enter a real value', '0.00')
</code>
</code>
</sample>
</sample>

Latest revision as of 15:14, 6 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function RealDialog displays a dialog box which requests the user to enter a REAL value. RealDialog automatically screens for valid numeric input.

FUNCTION RealDialog(
request :STRING;
default :STRING) : REAL;
def vs.RealDialog(request, default):
    return REAL

Parameters

request STRING Dialog user prompt string.
default STRING Default value for input field.

Example

VectorScript

RealValue:=RealDialog('Enter a real value:','0.00');

Python

realValue = vs.RealDialog('Enter a real value', '0.00')

Version

Availability: from All Versions