VS:ReadBin: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 43: Line 43:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>[[VS:WriteBin]] [[VS:Open]]</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 19:29, 12 September 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ReadBin will read binray data from a currently open file. The variable length parameter list returns the read data in the specified parameters.


Supported data types include INTEGER (2-bytes), REAL (8-bytes), LONGINT (4-bytes), CHAR (1-byte) or STRING/DYNARRAY OF CHAR (see remarks).

The bytes will be written as little-endian.

Strings will require additional INTEGER parameter to specify encoding: 0 – mac; 1 – win; 2 – system; 3 – UTF8; 4 – UTF16.

PROCEDURE ReadBin(
VAR z :ANY);
def vs.ReadBin():
    return z

Parameters

z ANY

Version

Availability: from MiniCAD

See Also

VS:WriteBin VS:Open

[[VS:WriteBin]] [[VS:Open]]