VS:ReadBin: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(wikify)
 
(2 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure ReadBin will read binray data from a currently open file. The variable length parameter list returns the read data in the specified parameters. <BR>
Procedure ReadBin will read binary data from a currently open file. The variable length parameter list returns the read data in the specified parameters.
<BR>
 
Supported data types include INTEGER (2-bytes), REAL (8-bytes), LONGINT (4-bytes), CHAR (1-byte) or STRING/DYNARRAY OF CHAR (see remarks). <BR>
Supported data types include INTEGER (2-bytes), REAL (8-bytes), LONGINT (4-bytes), CHAR (1-byte) or STRING/DYNARRAY OF CHAR (see remarks).
<BR>
 
The bytes will be written as little-endian. <BR>
The bytes will be written as little-endian.
<BR>
 
Strings will require additional INTEGER parameter to specify encoding: 0 – mac; 1 – win; 2 – system; 3 – UTF8; 4 – UTF16.</desc>
Strings will require additional INTEGER parameter to specify encoding:
: 0 – mac
: 1 – win
: 2 – system
: 3 – UTF8
: 4 – UTF16
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 37: Line 43:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 43: Line 50:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>[[VS:WriteBin]] [[VS:Open]]</seeAlso>
<seeAlso>[[VS:WriteBin]] | [[VS:Open]]</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from MiniCAD
Availability: from VW 2018


</version>
</version>

Latest revision as of 10:03, 25 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ReadBin will read binary data from a currently open file. The variable length parameter list returns the read data in the specified parameters.

Supported data types include INTEGER (2-bytes), REAL (8-bytes), LONGINT (4-bytes), CHAR (1-byte) or STRING/DYNARRAY OF CHAR (see remarks).

The bytes will be written as little-endian.

Strings will require additional INTEGER parameter to specify encoding:

0 – mac
1 – win
2 – system
3 – UTF8
4 – UTF16
PROCEDURE ReadBin(
VAR z :ANY);
def vs.ReadBin():
    return z

Parameters

z ANY

Version

Availability: from VW 2018

See Also

VS:WriteBin | VS:Open

[[VS:WriteBin]] | [[VS:Open]]