VS:RRect: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:36, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure RRect creates a rounded rectangle object in a VectorWorks document.

Corner definition is controlled by parameter Diam, which determines the "roundness" of the rectangle corners. The X and Y components of Diam correspond to the major and minor axes of an oval defining the rectangle corner.

PROCEDURE RRect(
p1X,p1Y :REAL;
p2X,p2Y :REAL;
DiamX,DiamY :REAL);
def vs.RRect(p1, p2, Diam):
    return None

Parameters

p1 REAL Top left coordinate of rectangle.
p2 REAL Bottom right coordinate of rectangle.
Diam REAL X and Y diameters of corner.

Example

VectorScript

PROCEDURE Example;
BEGIN
RRect(0, 0, 1, 1, 0.25, 0.25);
{ the same as: RRectangleN(0, 0, 1, 0, 1, 1, .25, .25); }
END;
RUN(Example);

Python


Version

Availability: from All Versions

See Also

VS Functions:

VS:Rect | VS:RRectangleN | VS:GetRRDiam

VS Functions:

[[VS:Rect]] | [[VS:RRectangleN]]

| [[VS:GetRRDiam]]