VS:QTSetMovieOptions

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the QuickTime movie frame rate and key frame rate for the referenced movie stream. The standard QuickTime compression options dialog can also be optionally displayed.

PROCEDURE QTSetMovieOptions(
movieRef :INTEGER;
frameRate :REAL;
keyFrameRate :LONGINT;
useDlg :BOOLEAN;
useDlgPreview :BOOLEAN);
def vs.QTSetMovieOptions(movieRef, frameRate, keyFrameRate, useDlg, useDlgPreview):
    return None

Parameters

movieRef INTEGER Index of QuickTime movie stream.
frameRate REAL Frame rate of movie.
keyFrameRate LONGINT Key frame rate of movie.
useDlg BOOLEAN Display QuickTime comprssion options dialog.
useDlgPreview BOOLEAN Show dialog preview.

Version

Availability: from VectorWorks8.5