VS:PtDialog3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure PtDialog3D displays a dialog box which requests the user to enter a 3D coordinate (point) value.

PROCEDURE PtDialog3D(
displayStr :STRING;
xStr :STRING;
yStr :STRING;
zStr :STRING;
VAR xPt :REAL;
VAR yPt :REAL;
VAR zPt :REAL);
def vs.PtDialog3D(displayStr, xStr, yStr, zStr):
    return (xPt, yPt, zPt)

Parameters

displayStr STRING Dialog user prompt string.
xStr STRING Default value for input field.
yStr STRING Default value for input field.
zStr STRING Default value for input field.
xPt REAL Returns user input X value.
yPt REAL Returns user input Y value.
zPt REAL Returns user input Z value.

Example

VectorScript

PtDialog3D('Enter the 3D location:','0','0','0',x,y,z);

Python

xPt, yPt, zPt = vs.PtDialog3D('User prompt string','0','0','0')

Version

Availability: from All Versions