VS:PtDialog

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure PtDialog displays a dialog box which requests the user to enter a coordinate (point) value.

PROCEDURE PtDialog(
request :STRING;
defaultX :STRING;
defaultY :STRING;
VAR x :REAL;
VAR y :REAL);
def vs.PtDialog(request, defaultX, defaultY):
    return (x, y)

Parameters

request STRING Dialog user prompt string.
defaultX STRING Default value for input field.
defaultY STRING Default value for input field.
x REAL Returns user input X value.
y REAL Returns user input Y value.

Example

VectorScript

PtDialog('Enter a coordinate.','0','0',cX,cY);

Python


Version

Availability: from All Versions