VS:Products3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the products of inertia of a 3D object for the xy, yz, and zx planes passing through a point at the center of gravity of the object.

FUNCTION Products3D(
obj :HANDLE;
VAR lxy :REAL;
VAR lyz :REAL;
VAR lzx :REAL) : BOOLEAN;
def vs.Products3D(obj):
    return (BOOLEAN, lxy, lyz, lzx)

Parameters

obj HANDLE The object from which to calculate the Products
lxy REAL Theh product of inertia with respect to the YZ and XZ planes passing through the center of mass of object.
lyz REAL Theh product of inertia with respect to the XZ and XY planes passing through the center of mass of object.
lzx REAL Theh product of inertia with respect to the XY and YZ planes passing through the center of mass of object.

Return Value

Returns true if the function succeeds.

Version

Availability: from VectorWorks10.1