VS:PrintUsingPrintDialog: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
 
Line 41: Line 41:
</return>
</return>


-----------------------------------------------------------------------------------------------------------
<sample>
==== VectorScript ====
<code lang="pas">
</code>
==== Python ====
<code lang="py">
result = vs.PrintUsingPrintDialog()
</code>
</sample>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>

Latest revision as of 21:13, 7 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Available in Industry Series products only. Prints the active document. The Print Dialog will be displayed. The PageSetup dialog will be displayed, before the print dialog, if the existing print settings are not valid for the current printer

FUNCTION PrintUsingPrintDialog : INTEGER;
def vs.PrintUsingPrintDialog():
    return INTEGER

Return Value

Return Value Status
0 User cancelled
1 Success
2 Failure

Remarks

Use GetEnabledModules to determine if an Industry Series product is installed.

Example

VectorScript


Python

result = vs.PrintUsingPrintDialog()

Version

Availability: from VectorWorks10.5