VS:PrimaryUnits

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure PrimaryUnits specifies the primary units settings for the active document. The primary units setting is used by the document for all measurement entry and display values in the document.


Table - Units Formats
Units Format Constant
Decimal 0
Fractional 1
Decimal Ft/Inches 2
Fractional Ft/Inches 3
Table - Standard Unit Settings
Units Setting Constant
Custom 0
Feet/Inches 1
Inches 2
Feet 3
Yards 4
Miles 5
Microns 6
Millimeters 7
Centimeters 8
Meters 9
Kilometers 10
PROCEDURE PrimaryUnits(
style :INTEGER;
prec :LONGINT;
dimPrec :LONGINT;
format :INTEGER;
angPrec :INTEGER;
showMark :BOOLEAN;
dispFrac :BOOLEAN);
def vs.PrimaryUnits(style, prec, dimPrec, format, angPrec, showMark, dispFrac):
    return None

Parameters

style INTEGER Active primary unit style for document.
prec LONGINT Display precision.
dimPrec LONGINT Dimension precision.
format INTEGER Decimal formatting.
angPrec INTEGER Angular precision.
showMark BOOLEAN Unit mark display setting.
dispFrac BOOLEAN Fractional display setting.

Remarks

[sd 8/18/98]

See GetPrimaryUnitInfo for details on changes in VW9 and again in VW12.

Example

VectorScript

PROCEDURE Example;
VAR
style :INTEGER;
prec, dimPrec :LONGINT;
format, angPrec :INTEGER;
showMark, dispFrac :BOOLEAN;
outStr :STRING;
BEGIN
outStr := '';
GetPrimaryUnitInfo(style, prec, dimPrec, format, angPrec, showMark, dispFrac);
FOR style := 0 to 16 DO BEGIN
PrimaryUnits(style, prec, dimPrec, format, angPrec, showMark, dispFrac);
outStr := Concat(outStr, Chr(13), style, ': ', GetPrefReal(152));
END;
AlrtDialog(outStr);
END;
RUN(Example);

Python


Version

Availability: from MiniCAD 7.0