VS:PolyMedialAxis

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Accepts a polygon and returns a group of lines representing the medial axis of the poly.

FUNCTION PolyMedialAxis(
h :HANDLE) :HANDLE;
def vs.PolyMedialAxis(h):
    return HANDLE

Parameters

h HANDLE

Example

PROCEDURE Example;
VAR
   h :HANDLE;
BEGIN
   {CallTool(-207);}
   h := FSActLayer;
   h := PolyMedialAxis(h);
END;
Run(Example);

Version

Availability: from All Versions

This is drop-in function.