VS:PolyMedialAxis: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Accepts a polygon and returns a group of lines representing the medial axis of the poly.
Creates a group of lines which represent the weighted medial axis of given polygon.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION PolyMedialAxis(h :HANDLE) :HANDLE;
FUNCTION PolyMedialAxis(h:HANDLE) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 29: Line 28:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
VAR
  h :HANDLE;
BEGIN
  {CallTool(-207);}
  h := FSActLayer;
  h := PolyMedialAxis(h);
END;
Run(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 17:35, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a group of lines which represent the weighted medial axis of given polygon.

FUNCTION PolyMedialAxis(
h :HANDLE) : HANDLE;
def vs.PolyMedialAxis(h):
    return HANDLE

Parameters

h HANDLE

Version

Availability: from Vectorworks 2014