VS:Plant UpdateTranslat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 1: Line 1:
{{LocationMain|category=LocationVS|specific=}}
{{LocationMain|category=LocationVS|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 11: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE Plant_UpdateTranslatedPlantIDRecord(newID:PROCEDURE);
PROCEDURE Plant_UpdateTranslat(newSymbolName:DYNARRAY[] of CHAR; oldID:DYNARRAY[] of CHAR; newID:DYNARRAY[] of CHAR; masterPlant:HANDLE; currentPlant:HANDLE);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 22: Line 21:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
newSymbolName
DYNARRAY[] of CHAR
</line>
<line>
oldID
DYNARRAY[] of CHAR
</line>
<line>
<line>
newID
newID
PROCEDURE
DYNARRAY[] of CHAR
 
</line>
<line>
masterPlant
HANDLE
 
</line>
<line>
currentPlant
HANDLE


</line>
</line>
Line 41: Line 60:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2011
Availability: from Vectorworks 2014


</version>
</version>
Line 47: Line 66:
</vwDoc>
</vwDoc>


[[Category:VS Function Reference|Plant_UpdateTranslatedPlantIDRecord]]
[[Category:VS Function Reference|Plant_UpdateTranslat]]
[[Category:VS Function Reference:PlantObjectCoreTools|Plant_UpdateTranslatedPlantIDRecord]]
[[Category:VS Function Reference:PlantObjectCoreTools|Plant_UpdateTranslat]]

Revision as of 17:37, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Updates the plant record with the new ID.

PROCEDURE Plant_UpdateTranslat(
newSymbolName :DYNARRAY[] of CHAR;
oldID :DYNARRAY[] of CHAR;
newID :DYNARRAY[] of CHAR;
masterPlant :HANDLE;
currentPlant :HANDLE);
def vs.Plant_UpdateTranslat(newSymbolName, oldID, newID, masterPlant, currentPlant):
    return None

Parameters

newSymbolName DYNARRAY[] of CHAR
oldID DYNARRAY[] of CHAR
newID DYNARRAY[] of CHAR
masterPlant HANDLE
currentPlant HANDLE

Version

Availability: from Vectorworks 2014