VS:PlanarPtTo3DModelPt

From Vectorworks Developer
Revision as of 17:41, 16 September 2010 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Transform a 2D point on the specified plane into a 3D point.

FUNCTION PlanarPtTo3DModelPt(
refID :LONGINT;
pt2D :REAL;
VAR outPt3D :REAL) : BOOLEAN;
def vs.PlanarPtTo3DModelPt(refID, pt2D):
    return (BOOLEAN, outPt3D)

Parameters

refID LONGINT Reference ID of the plane.
pt2D REAL The 2D point on the specified plane.
outPt3D REAL Output. The resulted 3D point.

Version

Availability: from Vectorworks 2011