VS:PlanarPtTo3DModelPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:35, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Transform a 2D point on the specified plane into a 3D point.

FUNCTION PlanarPtTo3DModelPt(
refID :LONGINT;
pt2D :REAL;
VAR outPt3D :REAL) : BOOLEAN;
def vs.PlanarPtTo3DModelPt(refID, pt2D):
    return (BOOLEAN, outPt3D)

Parameters

refID LONGINT Reference ID of the plane.
pt2D REAL The 2D point on the specified plane.
outPt3D REAL Output. The resulted 3D point.

Version

Availability: from Vectorworks 2011