VS:Perp

From Vectorworks Developer
Revision as of 14:35, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a vector which is perpendicular to the specified vector. The resultant vector will have the same magnitude as the source vector, and their scalar product will be zero. The direction of the return vector will equal Vec2Ang(Vec) - 90.

FUNCTION Perp(
Vec :VECTOR) : VECTOR;
def vs.Perp(Vec):
    return VECTOR

Parameters

Vec VECTOR Source vector.

Return Value

Returns a VECTOR.

Remarks

(Orso, 2011 Jan. 25) The z-value of the vector returned by Perp is always zero. If your source vector has z<>0 the resulting vector might not be what you expect, because of the source vector's angle.

Version

Availability: from All Versions