VS:PerimN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the perimeter of an object. If more than one object matches the search criteria, the function will return the sum of the matching objects' perimeters.

FUNCTION PerimN(
c :CRITERIA) : REAL;
def vs.PerimN(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

PerimValue := PerimN(C='Fence');
{returns the total perimeter of all objects in the class 'Fence'}

Version

Availability: from Vectorworks 2012