VS:PenPatN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand)
m (fix double date)
Line 33: Line 33:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): (Orso 2016.02.29): VS:FPenPatN requires a name list index, while the older routine VS:PenPat requires the dash style index. Please mind that a document doesn't necessarily have dash styles loaded.
([[User:Orso.b.schmid|Orso]] 2016.02.29): VS:FPenPatN requires a name list index, while the older routine VS:PenPat requires the dash style index. Please mind that a document doesn't necessarily have dash styles loaded.


<code lang='vs'>
<code lang='vs'>

Revision as of 02:50, 16 June 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure PenPatN sets the active pen pattern (line style) for the document.

If patNumber is in the range 0 to 71 the linestyle will be set to the corresponding fill pattern. A negative value, will set the linestyle to the line type resource whose index is the negative of the value.

PROCEDURE PenPatN(
patNumber :LONGINT);
def vs.PenPatN(patNumber):
    return None

Parameters

patNumber LONGINT Pattern/linestyle ID value.

Remarks

(Orso 2016.02.29): VS:FPenPatN requires a name list index, while the older routine VS:PenPat requires the dash style index. Please mind that a document doesn't necessarily have dash styles loaded.

PenPatN(-Name2Index('ISO-02 Dashed')); { makes 'ISO-02 Dashed' as the active pen pattern }

Example

PenPatN(25);
{ uses fill pattern 25 as the active pen pattern }

indx := Name2Index('ISO-02 Dashed');
PenPatN(-indx);
{ makes 'ISO-02 Dashed' as the active pen pattern }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:FPenPatN

VS Functions: [[VS:FPenPatN]]