VS:PenPat

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use PenPatN instead.

Procedure PenPat sets the active pen pattern (line style) for the document.

If patNumber is in the range 0 to 71 the linestyle will be set to the corresponding fill pattern. A value in the range -1 to -8, will set the linestyle to one of the defined VectorWorks linestyles.

Fill patterns and their associated constants can be found in the VectorScript Appendix.

PROCEDURE PenPat(
patNumber :INTEGER);
def vs.PenPat(patNumber):
    return None

Parameters

patNumber INTEGER Pattern/linestyle ID value.

Example

VectorScript

PenPat(25);
{ uses fill pattern 25 as the active pen pattern }

PenPat(-3);
{ sets a linestyle as the active pen pattern }

Python


Version

Availability: from All Versions, deprecated from Vectorworks 2013

See Also

PenPatN, FPenPatN from Vectorworks 2013

[[VS:PenPatN|PenPatN]], [[VS:FPenPatN|FPenPatN]] from Vectorworks 2013