VS:PenLoc: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
Line 38: Line 38:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
penLocation = vs.PenLoc()
vs.Message(str(penLocation))
</code>
</code>
</sample>
</sample>

Revision as of 21:09, 7 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the current coordinate location of the graphics pen.

PROCEDURE PenLoc(
VAR pX,pY :REAL);
def vs.PenLoc():
    return p

Parameters

p REAL The current location of the graphics pen.

Example

VectorScript

PenLoc(theXCoord,theYCoord);

Python

penLocation = vs.PenLoc()
vs.Message(str(penLocation))

Version

Availability: from All Versions