VS:PenBack: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (Transfer Orso to _c_)
 
(3 intermediate revisions by 2 users not shown)
Line 29: Line 29:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User:CBM-c-|_c_]] 2015.05.19: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with [[VS:RGBToColorIndex]]. See remarks under [[VS:SetPenFore]] for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index].
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
PenBack(65535,0,39321);
PenBack(65535, 0, 39321); { using RGB values }
 
colorIndex := RGBToColorIndex(65535, 0, 39321);
PenBack(colorIndex); { using Color Index values }
</code>
</code>
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
vs.PenBack((65535, 0, 39321)) # using RGB values


colorIndex = vs.RGBToColorIndex(65535, 0, 39321)
vs.PenBack(colorIndex) # using Color Index values
</code>
</code>
</sample>
</sample>

Latest revision as of 06:11, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure PenBack set the active pen background color for the document. RGB values are in the range of 0~65535.

PROCEDURE PenBack(
color :LONGINT);
def vs.PenBack(color):
    return None

Parameters

color LONGINT RGB color value to be set as active pen background.

Remarks

_c_ 2015.05.19: This Procedure will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Example

VectorScript

PenBack(65535, 0, 39321); { using RGB values }

colorIndex := RGBToColorIndex(65535, 0, 39321);
PenBack(colorIndex); { using Color Index values }

Python

vs.PenBack((65535, 0, 39321)) # using RGB values

colorIndex = vs.RGBToColorIndex(65535, 0, 39321)
vs.PenBack(colorIndex) # using Color Index values

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]