VS:PDF GetPageSizeFromBlob

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Takes Blob Data and returns corresponding page rect

FUNCTION PDF_GetPageSizeFromBlob(
inBlobPtr :PROCEDURE;
inBlobSize :LONGINT;
inPageBoxID :LONGINT;
inCurPage :PROCEDURE;
outBoxLeft :PROCEDURE;
outBoxTop :PROCEDURE;
outBoxRight :PROCEDURE;
outBoxBottom :PROCEDURE) : BOOLEAN;
def vs.PDF_GetPageSizeFromBlob(inBlobPtr, inBlobSize, inPageBoxID, inCurPage, outBoxLeft, outBoxTop, outBoxRight,  outBoxBottom):
    return BOOLEAN

Parameters

inBlobPtr PROCEDURE
inBlobSize LONGINT
inPageBoxID LONGINT
inCurPage PROCEDURE
outBoxLeft PROCEDURE
outBoxTop PROCEDURE
outBoxRight PROCEDURE
outBoxBottom PROCEDURE

Version

Availability: from Vectorworks 2014