VS:OverlapLineLine

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns two points the lap zone of two lines.

FUNCTION OverlapLineLine(
begPt1 :VECTOR;
endPt1 :VECTOR;
begPt2 :VECTOR;
endPt2 :VECTOR;
VAR lapPt1 :VECTOR;
VAR lapPt2 :VECTOR;
tolerance :REAL) : BOOLEAN;
def vs.OverlapLineLine(begPt1, endPt1, begPt2, endPt2, tolerance):
    return (BOOLEAN, lapPt1, lapPt2)

Parameters

begPt1 VECTOR
endPt1 VECTOR
begPt2 VECTOR
endPt2 VECTOR
lapPt1 VECTOR
lapPt2 VECTOR
tolerance REAL

Version

Availability: from Vectorworks 2014