VS:OverlapLineLine

From Vectorworks Developer
Revision as of 17:35, 18 September 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns two points the lap zone of two lines.

FUNCTION OverlapLineLine(
begPt1 :VECTOR;
endPt1 :VECTOR;
begPt2 :VECTOR;
endPt2 :VECTOR;
VAR lapPt1 :VECTOR;
VAR lapPt2 :VECTOR;
tolerance :REAL) : BOOLEAN;
def vs.OverlapLineLine(begPt1, endPt1, begPt2, endPt2, tolerance):
    return (BOOLEAN, lapPt1, lapPt2)

Parameters

begPt1 VECTOR
endPt1 VECTOR
begPt2 VECTOR
endPt2 VECTOR
lapPt1 VECTOR
lapPt2 VECTOR
tolerance REAL

Version

Availability: from Vectorworks 2014