VS:Open

From Vectorworks Developer
Revision as of 09:45, 25 December 2017 by CBM-c- (talk | contribs) (fix)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Open opens a ASCII text file for reading.

Remember to use Close when you are finished reading or writing to a file.


If the filename includes a fully qualified path, the path has to use the appropriate notation for the local operating system:

Macintosh HD:Applications:VectorWorks:Plug-Ins:Data:Notes.txt
C:\Program Files\VectorWorks\Plug-Ins\Data\Notes.txt


If the filename includes a path relative to the location of the VectorWorks executable, the subfolder delimiters have to be backslashes:

Plug-Ins\Data\Notes.txt


If the filename does not include a path, the file is assumed to exist in the same folder as the VectorWorks executable.

PROCEDURE Open(
fileName :STRING);
def vs.Open(fileName):
    return None

Parameters

fileName STRING Name of file to open.

Remarks

Absolute paths versus relative paths:

Accepts platform specific absolute paths, or windows delimited relative paths:

Accepts platform specific absolute paths only:

Returns platform specific absolute paths (user interactive):

Returns platform specific absolute paths (not user interactive):

Example

VectorScript

PROCEDURE Example;
VAR
fileName :STRING;
BEGIN
UseDefaultFileErrorHandling(FALSE);
fileName := 'Plug-InsCommonDataCallout Prefs.txt';
Open(fileName);
AlrtDialog(Concat(GetLastFileErr));
Close(fileName);
END;
RUN(Example);

Python


Version

Availability: from All Versions