VS:OffsetPolyN

From Vectorworks Developer
Revision as of 08:53, 14 July 2016 by Ptr (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Offsets a polygon or polyline. Uses Parasolid to do it. Equivalent of Voronoy based OffsetPoly.

FUNCTION OffsetPolyN(
h :HANDLE;
offsetDistance :REAL;
smoothCorners :BOOLEAN) : HANDLE;
def vs.OffsetPolyN(h, offsetDistance, smoothCorners):
    return HANDLE

Parameters

h HANDLE
offsetDistance REAL
smoothCorners BOOLEAN

Remarks

(Orso, 2011): It outputs a polygon (Type 5), polyline (Type 21) or a group (Type 11), according to the offset geometry and eventual intersections.

OffsetPolyN fails:

  • on holes, they are ignored
  • used from inside plug-in objects: deselects the object instance on drawing at each run, compelling the user to re-select (tested from VW 2011 through 2014, also in 2016).

Version

Availability: from Vectorworks 2009

See Also

Similar calls:

Similar calls:
  • [[VS:OffsetPoly]]
  • [[VS:OffsetHandle]]