VS:OffsetPolyN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Offsets a polygon or polyline. Uses Parasolid to do it. Equivalent of Voronoy based OffsetPoly.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION OffsetPolyN(h: HANDLE; offsetDistance: REAL; smoothCorners: BOOLEAN) : HANDLE;
FUNCTION OffsetPolyN(h:HANDLE; offsetDistance:REAL; smoothCorners:BOOLEAN) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
([[User:Orso.b.schmid|Orso]]: 05 Oct. 2010): This routine used in plug-in objects will cause the running plug-in instance to deselect upon any regen (tested VW13-16). See also [[VS:OffsetPoly| OffsetPoly]], which doesn't show this problem but on the other hand fails on metrical units whenever the offset is less than 1 unit.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
[[VS:OffsetPoly| OffsetPoly]]
[[VS:OffsetHandle| OffsetHandle]]
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|OffsetPolyN]]
[[Category:VS Function Reference|OffsetPolyN]]
[[Category:VS Function Reference:Objects - Polys|OffsetPolyN]]
[[Category:VS Function Reference:Graphic Calculation|OffsetPolyN]]

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Offsets a polygon or polyline. Uses Parasolid to do it. Equivalent of Voronoy based OffsetPoly.

FUNCTION OffsetPolyN(
h :HANDLE;
offsetDistance :REAL;
smoothCorners :BOOLEAN) : HANDLE;
def vs.OffsetPolyN(h, offsetDistance, smoothCorners):
    return HANDLE

Parameters

h HANDLE
offsetDistance REAL
smoothCorners BOOLEAN

Version

Availability: from Vectorworks 2014