VS:OffsetPolyN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(add remark)
(5 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Offsets a polygon or polyline. Uses Parasolid to do it. Equivalent of Voronoy based OffsetPoly.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION OffsetPolyN(h: HANDLE; offsetDistance: REAL; smoothCorners: BOOLEAN) : HANDLE;
FUNCTION OffsetPolyN(h:HANDLE; offsetDistance:REAL; smoothCorners:BOOLEAN) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark>
</return>
([[User:Orso.b.schmid|Orso]], 2020):
* smoothCorners will create rounded corners
* there is a suppression of collinear vertexes from the original object, so the resulting poly doesn't necessarily have the same count of vertexes.


-----------------------------------------------------------------------------------------------------------
([[User:Orso.b.schmid|Orso]], 2011): It outputs a polygon (Type 5), polyline (Type 21) or a group (Type 11), according to the offset geometry and eventual intersections.
<remark>
OffsetPolyN fails:
([[User:Orso.b.schmid|Orso]]: 05 Oct. 2010): This routine used in plug-in objects will cause the running plug-in instance to deselect upon any regen (tested VW13-16). See also [[VS:OffsetPoly| OffsetPoly]], which doesn't show this problem but on the other hand fails on metrical units whenever the offset is less than 1 unit.
* on holes, they are ignored
* used from inside plug-in objects: deselects the object instance on drawing at each run, compelling the user to re-select (tested from VW 2011 through 2014, also in 2016).
</remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample></sample>


</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
Similar calls:
* [[VS:OffsetPoly]]
* [[VS:OffsetHandle]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2009


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
[[VS:OffsetPoly| OffsetPoly]]
[[VS:OffsetHandle| OffsetHandle]]
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|OffsetPolyN]]
[[Category:VS Function Reference|OffsetPolyN]]
[[Category:VS Function Reference:Objects - Polys|OffsetPolyN]]
[[Category:VS Function Reference:Graphic Calculation|OffsetPolyN]]

Revision as of 09:34, 3 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Offsets a polygon or polyline. Uses Parasolid to do it. Equivalent of Voronoy based OffsetPoly.

FUNCTION OffsetPolyN(
h :HANDLE;
offsetDistance :REAL;
smoothCorners :BOOLEAN) : HANDLE;
def vs.OffsetPolyN(h, offsetDistance, smoothCorners):
    return HANDLE

Parameters

h HANDLE
offsetDistance REAL
smoothCorners BOOLEAN

Remarks

(Orso, 2020):

  • smoothCorners will create rounded corners
  • there is a suppression of collinear vertexes from the original object, so the resulting poly doesn't necessarily have the same count of vertexes.

(Orso, 2011): It outputs a polygon (Type 5), polyline (Type 21) or a group (Type 11), according to the offset geometry and eventual intersections. OffsetPolyN fails:

  • on holes, they are ignored
  • used from inside plug-in objects: deselects the object instance on drawing at each run, compelling the user to re-select (tested from VW 2011 through 2014, also in 2016).

Version

Availability: from Vectorworks 2009

See Also

Similar calls:

Similar calls:
  • [[VS:OffsetPoly]]
  • [[VS:OffsetHandle]]