VS:OffsetHandle: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix example)
(reduce script)
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
<code lang="pas">PROCEDURE tryOffsetH;
<code lang="pas">PROCEDURE try;
VAR
VAR
prevLObj, sourcePoly, h : HANDLE;
prevLObj, sourceObj, h : HANDLE;
BEGIN
BEGIN
sourcePoly := FSActLayer;
sourceObj := FSActLayer;
IF (sourcePoly <> NIL) THEN BEGIN
IF (sourceObj <> NIL) THEN BEGIN
{ bug: h2 won't set with OffsetHandle until VW 2014 }
prevLObj := LObject; { store for later comparison }


h := OffsetHandle(sourcePoly, -10, TRUE, TRUE); { negative offset -10mm }
{ h won't set with OffsetHandle until VW 2014 }
h := LObject;  
prevLObj := LObject; { only before VW 2014: store for later comparison }


IF (prevLObj <> NIL) & (prevLObj <> h) THEN BEGIN
h := OffsetHandle(sourceObj, -10, TRUE, TRUE); { negative offset -10mm }
h := LObject; { only before VW 2014: this should be now the product of OffsetHandle }
 
IF (prevLObj <> h) THEN BEGIN
Message('Type: ', GetType(h), ' - ', h);
Message('Type: ', GetType(h), ' - ', h);
ResetObject(h);
ResetObject(h);
HUngroup(h);
HUngroup(h);
SetDSelect(sourcePoly);
SetDSelect(sourceObj);
END;
END;
END;
END;
END;
END;
Run(tryOffsetH);</code>
Run(try);</code>
</sample>
</sample>



Revision as of 05:10, 26 March 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a group of lines which represent the weighted medial axis of given polygon.

FUNCTION OffsetHandle(
h :HANDLE;
offsetDistance :REAL;
EdgeRestoration :BOOLEAN;
FilletSharpEdges :BOOLEAN) : HANDLE;
def vs.OffsetHandle(h, offsetDistance, EdgeRestoration, FilletSharpEdges):
    return HANDLE

Parameters

h HANDLE
offsetDistance REAL
EdgeRestoration BOOLEAN
FilletSharpEdges BOOLEAN

Remarks

(Orso, 2014.03.25): The routine was introduced undocumented by VW11 (2006).

Warning:

  • The parameter offsetDistance takes mm, unregarded unit's settings.
  • If you pass a polygon/polyline it outputs a group containing a polygon/polyline, not a group of lines.
  • Polyline holes are ignored
  • Undo fails on this action: you should consider carefully if using this routine
VW 2011, 2012, 2013
the handle h doesn't set. Use LObject to grab the handle. This is dangerous, if the routine fails, LObject will be something else: store LObject before running the script and afterwards and compare. If they are different the routines succeeded.
VW 2014
the handle will set as expected, undo still fails

Example

PROCEDURE try;
VAR
	prevLObj, sourceObj, h : HANDLE;
BEGIN
	sourceObj := FSActLayer;
	IF (sourceObj <> NIL) THEN BEGIN

		{ h won't set with OffsetHandle until VW 2014 }
		prevLObj := LObject; { only before VW 2014: store for later comparison }

		h := OffsetHandle(sourceObj, -10, TRUE, TRUE); { negative offset -10mm }
		h := LObject; { only before VW 2014: this should be now the product of OffsetHandle }

		IF (prevLObj <> h) THEN BEGIN
			Message('Type: ', GetType(h), ' - ', h);
			ResetObject(h);
			HUngroup(h);
			SetDSelect(sourceObj);
		END;
	END;
END;
Run(try);

Version

Availability: from Vectorworks 2014

See Also

Similar calls:

Similar calls:
  • [[VS:OffsetPoly]]
  • [[VS:OffsetPolyN]]