VS:ObjectType

From Vectorworks Developer
Revision as of 21:46, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the type identifier an object. If more than one object matches the search criteria, the type identifier of the last matching object will be returned.

FUNCTION ObjectType(
c :CRITERIA) : INTEGER;
def vs.ObjectType(c):
    return INTEGER

Parameters

c CRITERIA Search criteria.

Example

TypeValue:=ObjectType(N='Mystery Object');
{returns the type of the object named 'Mystery Object'}

Version

Availability: from All Versions