VS:ObjectType

From Vectorworks Developer
Revision as of 14:08, 13 June 2014 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the type identifier an object. If more than one object matches the search criteria, the type identifier of the last matching object will be returned.

FUNCTION ObjectType(
c :CRITERIA) : INTEGER;
def vs.ObjectType(c):
    return INTEGER

Parameters

c CRITERIA Search criteria.

Example

VectorScript:

TypeValue:=ObjectType(N='Mystery Object');
{returns the type of the object named 'Mystery Object'}

Python:

TypeValue = vs.ObjectType( "N='Mystery Object'" );
# returns the type of the object named 'Mystery Object'

Version

Availability: from All Versions