VS:ObjectType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 34: Line 34:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
VectorScript:
<code lang="pas">
<code lang="pas">
TypeValue:=ObjectType(N='Mystery Object');
TypeValue:=ObjectType(N='Mystery Object');
{returns the type of the object named 'Mystery Object'}</code>
{returns the type of the object named 'Mystery Object'}</code>
Python:
<code lang="py">
TypeValue = vs.ObjectType( "N='Mystery Object'" );
# returns the type of the object named 'Mystery Object'
</code>
</sample>
</sample>



Latest revision as of 14:08, 13 June 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the type identifier an object. If more than one object matches the search criteria, the type identifier of the last matching object will be returned.

FUNCTION ObjectType(
c :CRITERIA) : INTEGER;
def vs.ObjectType(c):
    return INTEGER

Parameters

c CRITERIA Search criteria.

Example

VectorScript:

TypeValue:=ObjectType(N='Mystery Object');
{returns the type of the object named 'Mystery Object'}

Python:

TypeValue = vs.ObjectType( "N='Mystery Object'" );
# returns the type of the object named 'Mystery Object'

Version

Availability: from All Versions