VS:OLDSetLoadDataStr

From Vectorworks Developer
Revision as of 18:13, 21 May 2020 by Ykostadinov (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Using selector, sets load data with string value for the parametric object

Available selectors : kDLDSelectorGroupName = 2, kDLDSelectorLoadID = 3, kDLDSelectorLoadName = 4, kDLDSelectorPrmLoadID = 6, kDLDSelectorPrmName = 7, kDLDSelectorPrmWeight = 8, kDLDSelPrmTotalDistWght = 9.
Selector kDLDSelectorGroupName determinate the category, where the load will be displayed in the overview. This selector can be used with one of the following values: 'Audio', 'Video', 'Light', 'Decoration', 'Cable', 'Truss' and 'LoadingPoint'.

PROCEDURE OLDSetLoadDataStr(
handle :HANDLE;
selector :INTEGER;
value :STRING;
loadIndex :INTEGER);
def vs.OLDSetLoadDataStr(handle, selector, value, loadIndex):
    return None

Parameters

handle HANDLE
selector INTEGER
value STRING
loadIndex INTEGER

Version

Availability: from Vectorworks 2018