VS:OLDGetPositionTransf

From Vectorworks Developer
Revision as of 22:36, 12 September 2018 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retunrs TRUE if the position, where the load is attached, is moved/rotated. Get the offset applied to the load in object local coordinates and the rotataion angle applied to the position. HasWitnessLine point weather the object is alredy connected via a witness line

FUNCTION OLDGetPositionTransf(
handle :HANDLE;
loadIndex :INTEGER;
VAR offsetDistance :VECTOR;
VAR rotationAngle :REAL;
VAR hasWitnessLine :BOOLEAN) : BOOLEAN;
def vs.OLDGetPositionTransf(handle, loadIndex):
    return (BOOLEAN, offsetDistance, rotationAngle, hasWitnessLine)

Parameters

handle HANDLE
loadIndex INTEGER
offsetDistance VECTOR
rotationAngle REAL
hasWitnessLine BOOLEAN

Version

Availability: from Vectorworks 2019