VS:NurbsSetWeight

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the weight of a point in a NURBS curve or surface.

For NURBS curves, index1 corresponds to the segment of the curve to be queried, and index2 corresponds to the index of the point in the segment.

For NURBS surfaces, index1 corresponds to the u-index and index2 corresponds to the v-index of the surface.

The index is zero based (0 to number of points - 1).

PROCEDURE NurbsSetWeight(
objectHd :HANDLE;
index1 :LONGINT;
index2 :LONGINT;
weight :REAL);
def vs.NurbsSetWeight(objectHd, index1, index2, weight):
    return None

Parameters

objectHd HANDLE Handle to NURBS curve or surface.
index1 LONGINT Segment of curve to be queried (NURBS curve), or u-index (NURBS surface).
index2 LONGINT Index of point (NURBS curve) or v-index (NURBS surface).
weight REAL New weight of point.

Remarks

this function will work for both nurbs curves and nurbs surfaces

Version

Availability: from VectorWorks9.0